Places to get a newer version of PHP (and mysql-php) for RHEL5: