Software that supports Ruby's 'slim' gem: